IIS和4.0安装到底有没有先后顺序解答

发布时间:2017-03-22 12:13 来源:互联网 当前栏目:web技术类

在很多人或许很多技术大神都会觉得IIS的安装和4.0没得先后顺序的。其错误弊端在与IIS没有注册到4.0上。

微信彩票注册群经过今天遇到了服务器安装服务端发觉报错【无法识别的属性“targetFramework”。请注意属性名称区分大小写。错误解决办法】客户端报404错误,这个时候我们都会觉得没有找到相对应的路径。

解决办法:修改.NET Framework 版本为相应版本即可,我以前用的是2.0换成4.0的时候出现这个错误。

1、打开IIs点击IIS根节点

2、看右边的“操作”-》点击“更改.NET Framework 版本”

3、选择相应的版本,我这里应该选择v4.0.30319,点击确定

微信彩票注册群4、点击IIS的应用程序池

5、在右边“操作”栏里选择“应用程序默认设置...”

6、把“.NET Framework 版本”设置为v4.0,点击“确定”即可

微信彩票注册群7、打开ISAPI和CGI限制

8、找到你需要但被设为不允许运行的版本

9、把需要运行的版本设置为“允许”,即可

10、改变其权限,找到C盘windos->Temp右键->安全【编辑】->添加用户IIS_IUSER添加完全控制权限即可。-----------------------------经过实验这一步尤其重要。

本文由多方面技术组合得出最后结果。最终结果如下,完美解决,效果图如下.

最后给出结论,IIS和4。0安装还是有先后顺序的哈。

微信彩票注册群以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持脚本之家。

  • 1、
  • 2、
  • 3、
  • 4、
  • 5、
  • 6、
  • 7、
  • 8、
  • 9、
  • 10、
  • 11、
  • 12、
  • 13、
  • 14、
  • 15、
  • 16、
  • 17、
  • 18、
  • 19、
  • 20、
  • 21、
  • 22、
  • 23、
  • 24、
  • 25、
  • 1、
  • 2、
  • 3、
  • 4、
  • 5、
  • 6、
  • 7、
  • 8、
  • 9、
  • 10、
  • 11、
  • 12、
  • 13、
  • 14、
  • 15、
  • 16、
  • 17、
  • 18、
  • 19、
  • 20、
  • 21、
  • 22、
  • 23、
  • 24、
  • 25、